2017-10-21 19 views
0

我需要使用一些sass文件直接在我的angular4应用程序中。为此,我已经安装了节点sass,指南针compass-mixins用于转换&构建这些文件。但是当我试图运行我的应用程序时,它抛出了一个错误“没有mixin命名为动画”。有人能告诉我为什么会出现这个错误吗?使用scss文件编译angular4应用程序时出错

依赖性和版本:

"node-sass": "^4.5.3", "compass": "^0.1.1", "compass-mixins": "^0.12.10"

SCSS文件内容:

@import "~compass-mixins/lib/compass"; 

    .spinner { 
      opacity: 0.5; 
      @include animation (rotate 2s linear infinite backwards); 
     } 

实际的错误:

error image

回答

0

尝试更新您的import到:

@import "~compass-mixins/lib/_compass";

+0

我试过了,但没有奏效。 –

相关问题