2017-12-27 408 views
0

我们有一个VM正在开发,但在这些机器上,我们绝对没有互联网连接。本地机器可以访问互联网,但在那里没有Eclipse(这是公司的政策,他们必须非常严格)。Eclipse手动/脱机JBoss Tools Luna安装:缺少需求abc需要'bundle xyz',但找不到

Luna版本是4.4(本质上是IBM RAD 9.5开发工具叹息,但这对我的问题应该没有问题)。为月神最新的稳定是JBoss的工具4.2.3这里:https://tools.jboss.org/downloads/jbosstools/luna/4.2.3.Final.html

我终于下载了一个名为(不记得在哪里)

jbosstools,4.2.3.Final_2015-03-26_22-41-56 -B370-updatesite-core.zip

,其包括两个子目录pluginsfeatures和两个所需的文件和artifacts.jarcontent.jarHow to install plugin for Eclipse from .zip)。然后,我去了Eclipse帮助 - >安装新软件 - >添加... - >存档...并选择了我下载的文件(您可以通过Ctrl + C和Ctrl-V将文件从本地机器复制到VM ,但禁止访问互联网)。

手动安装失败。我唯一入选的功能的一小部分,以获得JSF编辑:

  • JBoss的工具JSF
  • JBoss的工具可视化页面编辑器

经过很长的时间完成一些冗长的15个计算步骤之后(“无法执行操作...步骤x/15,这可能需要一段时间。”对话说:

Cannot complete the install because one or more required items could not be found. 
    Software being installed: JBoss Tools JSF 3.6.2.Final-v20150325-0431-B95 (org.jboss.tools.jsf.feature.feature.group 3.6.2.Final-v20150325-0431-B95) 
    **Missing requirement: JBoss Tools Common Core 3.6.2.Final-v20150325-0456-B99 (org.jboss.tools.common.core 3.6.2.Final-v20150325-0456-B99) requires 'bundle org.apache.commons.httpclient 3.1.0' but it could not be found** 
    Cannot satisfy dependency: 
    From: JBoss Tools Common 3.6.2.Final-v20150325-0456-B99 (org.jboss.tools.common 3.6.2.Final-v20150325-0456-B99) 
    To: bundle org.jboss.tools.common.core 3.4.0 
    Cannot satisfy dependency: 
    From: El Plug-in 3.6.2.Final-v20150325-0456-B99 (org.jboss.tools.common.el.core 3.6.2.Final-v20150325-0456-B99) 
    To: bundle org.jboss.tools.common 0.0.0 
    Cannot satisfy dependency: 
    From: JBoss Tools Common 3.6.2.Final-v20150325-0456-B99 (org.jboss.tools.common.feature.feature.group 3.6.2.Final-v20150325-0456-B99) 
    To: org.jboss.tools.common.el.core [3.6.2.Final-v20150325-0456-B99] 
    Cannot satisfy dependency: 
    From: JBoss Tools JSF 3.6.2.Final-v20150325-0431-B95 (org.jboss.tools.jsf.feature.feature.group 3.6.2.Final-v20150325-0431-B95) 
    To: org.jboss.tools.common.feature.feature.group 3.6.0 

目前我坚持要安装所需的归档(S)Apache commons-httpclient-3.1.0手动将转换为Eclipse(而不是项目),因为我不知道在哪里可以找到包含commons-httpclient 3.1.0 Eclipse updatesite文件的ZIP文件。

问题/ S:

如何/我在哪里可以得到ZIP文件手动在Eclipse(回到updateSite文件)安装? 有谁知道该网址?

我需要将文件下载到我的本地计算机,通过RDC将其复制到虚拟机并在离线安装。

一般问题是在哪里可以找到任何依赖项的Eclipse更新文件。我相信commons-httpclient不会成为我唯一的问题。

谢谢

回答