2010-12-08 3 views
5

标题几乎说明了一切。如果我在我的项目中包含用于jQuery的Asual Address plugin,则IE6会向用户发出有关“安全和非安全项目”的警告。我剥一个页面下来无非是:jQuery Asual地址插件导致IE6“不安全项目”警告

<html xmlns="http://www.w3.org/1999/xhtml"> 
    <head runat="server"> 
     <title>Title</title> 
    </head> 
<body> 
    <script src="js/jquery.1.4.4.min.js" type="text/javascript"></script> 

    <script src="js/jquery.address-1.3.min.js" type="text/javascript"></script> 

</body> 
</html> 

放置在一个安全的网站和IE6将抛出警告。我在源代码中查找了一个iframe"about:blank"src标签的常见肇事者,但没有看到任何看起来像是问题的东西。

任何帮助表示赞赏。

更新:我试过了提琴手来确定非安全物品来自哪里。列出的唯一三件事是:

200 HTTPS CONNECT   *websiteurl*:443 
200 HTTPS *websiteurl* Default.aspx 
200 HTTPS *websiteurl* /js/jquery.1.4.4.min.js 
200 HTTPS *websiteurl* /js/jquery.address-1.3.min.js 

区别是,如果我点击“否”加载不安全的项目。我得到

200 HTTPS CONNECT   *websiteurl*:443 
200 HTTPS *websiteurl* Default.aspx 
200 HTTPS *websiteurl* /js/jquery.1.4.4.min.js 
200 HTTPS *websiteurl* /js/jquery.address-1.3.min.js 
400 HTTPS *websiteurl* pagerror.gif 

我已经研究了pagerror.gif,但它来了,我已经告诉IE 后加载不安全的内容,所以我不知道它与我的问题。

+0

哎呀对不起,我的假(已删除)答案 - 我完全误解了关于'