2012-03-02 198 views
0

我正在使用Ubuntu 11.10并从Ubuntu软件中心安装Eclipse。以下是我下载的Eclipse的信息。我的Java SDK 6和7,但是Eclipse配置为使用Java SDK 6Android ADT安装错误

Version: 3.7.0 
Build id: I20110613-1736 

我击球的时候在安装第一下一页按钮后正要安装ADT插件在Eclipse上这些错误告诉我我不能安装ADT,除非:

Cannot complete the install because one or more required items could not be found. 
    Software being installed: Android Development Tools 16.0.1.v201112150204-238534 (com.android.ide.eclipse.adt.feature.group 16.0.1.v201112150204-238534) 
    Missing requirement: Android Development Tools 16.0.1.v201112150204-238534 (com.android.ide.eclipse.adt.feature.group 16.0.1.v201112150204-238534) requires 'org.eclipse.wst.sse.core 0.0.0' but it could not be found 

我该如何解决这个问题?

在此先感谢。

+0

也许你应该先查找一下:[link](http://stackoverflow.com/questions/4249695/adt-requires-org-eclipse-wst-sse-core-0-0-0-但它不可能被发现) – IamAlexAlright 2012-03-02 20:52:47

回答

4

第一个建议是不要从任何Linux软件包管理器或软件存储库安装Eclipse。相反,只需从http://www.eclipse.org/downloads/得到它。 Linux发行版的安装版本经常被修改(有些人会说,会发生损坏)。

您遇到的特定错误是因为ADT需要部分Eclipse WST项目功能,但您配置的更新站点不包含WST。从http://www.eclipse.org/downloads/直接获取其中一个包可以解决这个问题,并且知道你得到的是什么(而不是依靠谁来组装Ubuntu的包)。

2

我有类似的问题,上面的回答没有工作,在这种情况下可以尝试:

  • 删除工作区目录

  • 检查运行Eclipse作为根(只为这ADT安装的持续时间)

更多信息看帖半途这个线程:

http://androidforums.com/galaxy-nexus-all-things-root/466275-having-trouble-installing-adt-plugin.html

+0

如果你想保留Ubuntu的Eclipse版本,链接是好的。此外,此步骤可能会针对Android SDK中的“adb”文件进行其他调整。 – 2012-04-08 14:19:26

+0

我的解决方案也是以root身份运行(通过gksudo)。如果问题是由发行版提供的eclipse版本缺少某些文件,那么以root身份运行如何解决此问题? (不是因为我对Linux没有经验 - 只是好奇而已)。 – 2012-07-11 00:41:30