2017-06-20 695 views
0

目前看来,我需要在我的Cordova应用程序中支持Android 4.x。 的该应用的功能最工作得很好,但我靠着不使太清楚在较旧的Android版本的一对夫妇库:只为Android添加Crosswalk <5.0

(我可疑的是,旧的Android浏览器不相当正确处理不同的堆叠上下文 - 画廊和演练弹出窗口上的按钮不响应事件;相反,它们后面的UI。)

无论如何,有没有办法使用Crosswalk Cordova插件只适用于Android 4.x版本

回答

1

您可以手动更改插件支持的android版本,方法是将其设置在插件的plugin.xml中。插件的plugin.xml可以在yourRootFolder/plugins/crosswalkPluginFolder/plugin.xml中找到。您应该能够看到类似的东西

<engine name="cordova-android" version="&gt;=5.1.1 &lt;7" /> 

您可以在此处指定最小和最大版本。