2017-04-02 116 views
1

我有一个Centos 7,安装了php 5.6.3。将php 5.6.3升级到5.6.4或更高版本(分支5.6)

php -v 
PHP 5.6.30 (cli) (built: Jan 19 2017 07:08:58) 

现在我想安装一个开源项目,需要最低的PHP版本5.6.4。

(*) PHP 5.6.0 - 5.6.3 are not compatible caused by a session bug 

我该如何升级? 我尝试了很多howto的google搜索,但都没有成功。例如: https://www.centos.org/forums/viewtopic.php?t=52586 当然,我有最新的(我认为)回购:

包webtatic释放小7-3.noarch已经安装

包EPEL释放,7-9。已安装noarch和最新版本

当我运行

yum update php 

我得到:

... 
Package(s) php available, but not installed. 
No packages marked for update 

或:

yum -y upgrade php* 

我得到:

Loaded plugins: fastestmirror, replace 
Loading mirror speeds from cached hostfile 
* base: mirrors.hostingfuze.net 
* extras: centos.mirrors.telekom.ro 
* ius: ftp.astral.ro 
* remi-safe: mirrors.neterra.net 
* updates: centos.mirrors.telekom.ro 
No packages marked for update 

所以基本上我的问题是:我怎么才能安装PHP 5.6.4或我的系统上已有较高PHP 5.6.3

+2

5.6.30比5.6.4('30> 4')更新 - 它是5.6分支的最新版本。版本5.6.4于2014年底发布。 – ccKep

+0

谢谢。我没有这样看。很高兴知道。将您的评论作为答案,我可以接受它 –

回答

0

试试这个:

yum install -y http://dl.iuscommunity.org/pub/ius/stable/CentOS/7/x86_64/ius-release-1.0-14.ius.centos7.noarch.rpm 
yum -y update 
yum -y install php70u php70u-pdo php70u-mysqlnd php70u-opcache php70u-xml php70u-mcrypt php70u-gd php70u-devel php70u-mysql php70u-intl php70u-mbstring php70u-bcmath php70u-json php70u-iconv 

或检查此链接:https://stackoverflow.com/a/40406823/7804966

+0

对不起,我必须在问题中指定我想坚持5.6分支而不去7分支 –

1

正如changelog看出,30年6月5日(今天的)的5.6分支的最新版本,5.6.4出来了2014年12月