2014-09-27 168 views
0

我对使用OpenTSDB感兴趣。在审查时,依赖我看到的第一件事情:OpenTSB可以安装在Windows上吗?

http://opentsdb.net/docs/build/html/installation.html#runtime-requirements

要实际运行OpenTSDB,则需要满足以下条件:

•Linux系统

•Java运行时环境1.6或更高版本

•HBase的0.92或更高版本

•GNUPLOT 4.2或更高版本

是否可以在Windows上运行OpenTSDB?我希望能够为我的应用程序的用户提供在Linux或Windows上运行的能力(因此主要使用Java,Apache等进行开发)。

在两个操作系统上运行的TS db有哪些选项?

回答

0

是的,OpenTSDB已经在Windows上工作过,但你可能无法使它运行。要构建它并获得依赖关系,您必须模拟autotools和wget或其等价物来完成这项工作。构建脚本假定Linux文件系统有一两件事。你需要一个Windows版本的GNUPlot。别的东西可能会出现,但没有你不应该能够克服的。当然,你会在没有太大困难的情况下让HBase在Windows上运行。

相关问题