2010-05-13 138 views
3

我使用RHEL 5.3,附带gcc 4.1.2和boost 1.33。 因此,没有boost :: unorded_map,没有make_shared()工厂函数来创建boost :: shared_ptr和其他更新版本的boost功能。升级升级版本

是否有更新版本的boost与gcc版本兼容? 如果是,升级如何执行?

回答

1

当然,只需从link text下载最新的源代码。如果你只使用头文件库,它只需要解压。如果您正在使用少数需要图书馆的软件,您需要构建这些软件。

3

只需downloadinstall最新版本;它会自动适应你的编译器。

+0

不知道这是否正确。我刚刚下载并安装了1.58和'cat /usr/include/boost/version.hpp | grep“define BOOST_LIB_VERSION”'仍然产生1.54? – knutole 2015-04-22 12:20:05