2016-05-15 54 views
0

我必须将我的python版本从3.5下载到3.4,因为我需要的一个软件包在3.5中不受支持。我使用conda命令提示符降级了python版本,并且一切正常 - 让我的软件包以其所有依赖项安装并且没有冲突。但是现在,当我尝试打开Juypter笔记本或Spyder时,没有任何反应。我的IPython工作得很好。我想也许我必须降级Juypter和Spyder,但我不确定。有人有主意吗?spyder/juypter在降级后不工作python

+0

'conda list'的输出是什么? –

回答

1

经过一天的搜索,我终于找到了答案。 我最初使用

conda install python=3.4 

坏主意 - 最后不得不进行全新安装Anaconda来获得的Spyder和juypter再次合作。

最终工作是创造一个单独的环境。

conda create -n py34 python=3.4 anaconda 
activate py34 
... then install packages ... 

这添加了spyder(py34),juypter(py34)和它的所有“py34兄弟姐妹”到我的开始菜单。使用这些新的快捷键/环境,我现在可以通过选择适当的快捷方式来访问我需要的软件包。是的,我的开始菜单现在有额外的python快捷键,但无论如何 - 它的工作原理。

只要确保在关闭anaconda控制台之前安装要查找的软件包。适合安装theano依赖关系mingwlibpython