2017-09-14 36 views
1

要在Android项目中包含recyclerview,我们使用recyclerview的所有版本在哪里?

compile 'com.android.support:recyclerview-v7:26.0.2'

我想知道gradle在哪里得到recyclerview包。我如何知道以前版本的recyclerview?

我已经在maven和jcenter中搜索recyclerview包,但没有得到任何结果。

+2

谁告诉你,那就是用recyclerView图书馆?正确的库是com.android.support:recyclerview-v7:25.3.1 – Rachit

回答

-1

你必须使用编译 'com.android.support:recyclerview-v7:26.0.2'库回收站视图。

0

要包括你必须在你的build.gradle添加RecyclerView:我已搜查在Maven和jcenter recyclerview包

compile 'com.android.support:recyclerview-v7:26.0.2' 

,但没有结果。

recyclerview包含在SDK管理器(如此地方)中。现在,因为该25.4.0的RecyclerView库部署在谷歌行家回购和要求:

allprojects { 
    repositories { 
     jcenter() 
     maven { 
      url "https://maven.google.com" 
     } 
    } 
} 

我怎么能知道recyclerview的所有先前版本?

您可以找到list hereold versions here

您也可以找到other info here:

//it requires compileSdkVersion 26 
    //it requires to add the google maven repo 
    // maven { 
    //  url "https://maven.google.com" 
    //  } 
    compile 'com.android.support:recyclerview-v7:26.0.2' 
    compile 'com.android.support:recyclerview-v7:26.0.1' 
    compile 'com.android.support:recyclerview-v7:26.0.0' 

    //it requires compileSdkVersion 25 
    compile 'com.android.support:recyclerview-v7:25.4.0' 
    compile 'com.android.support:recyclerview-v7:25.3.1' 
    compile 'com.android.support:recyclerview-v7:25.3.0' 
    compile 'com.android.support:recyclerview-v7:25.2.0' 
    compile 'com.android.support:recyclerview-v7:25.1.1' 
    compile 'com.android.support:recyclerview-v7:25.1.0' 
    compile 'com.android.support:recyclerview-v7:25.0.0' 

    //it requires compileSdkVersion 24 
    compile 'com.android.support:recyclerview-v7:24.1.1' 
    compile 'com.android.support:recyclerview-v7:24.1.0' 

    //it requires compileSdkVersion 23 
    compile 'com.android.support:recyclerview-v7:23.4.0' 
    compile 'com.android.support:recyclerview-v7:23.3.0' 
    compile 'com.android.support:recyclerview-v7:23.2.1' 
    compile 'com.android.support:recyclerview-v7:23.2.0' 
    compile 'com.android.support:recyclerview-v7:23.1.1' 
    compile 'com.android.support:recyclerview-v7:23.1.0' 
    compile 'com.android.support:recyclerview-v7:23.0.1' 
    compile 'com.android.support:recyclerview-v7:23.0.0' 

    //it requires compileSdkVersion 22 
    compile 'com.android.support:recyclerview-v7:22.2.1' 
    compile 'com.android.support:recyclerview-v7:22.2.0' 
    compile 'com.android.support:recyclerview-v7:22.1.1' 
    compile 'com.android.support:recyclerview-v7:22.1.0' 
    compile 'com.android.support:recyclerview-v7:22.0.0' 

    //it requires compileSdkVersion 21 
    compile 'com.android.support:recyclerview-v7:21.0.3' 
    compile 'com.android.support:recyclerview-v7:21.0.2' 
    compile 'com.android.support:recyclerview-v7:21.0.0' 
+0

谢谢!但我使用recyclerview库而不使用 'maven url“https://maven.google.com” } '这个存储库默认包含在maven中吗? –

+0

@ XiangZhang号它取决于版本。该v26只在谷歌回购。检查官方文档。 –

相关问题