2017-03-08 47 views
0

当我打电话康达无法更新Spyder的依赖

conda update spyder 

,然后打开Spyder的,我得到了下面的错误。

enter image description here

conda update应该更新安装的软件包的依赖?

解决此问题的最佳方法是什么?

我应该打电话给conda install jedi吗?

+1

据我所知,'畅达更新package'只更新'package',并且不考虑依赖关系。你的最佳行动方式确实是安装'jedi'。我不会把这个作为一个答案,因为我没有通过畅达源去核实:-) – darthbith

+0

有趣。看起来这会使'conda update'不太有用。也许'conda安装'与最新版本的软件包安装是一个更好的方法。 – user3731622

回答

2

发生这种情况,因为康达的缺省信道(WIN-64)的repodata.json,指定jedi>=0.8

"spyder-3.0.0-py34_0.tar.bz2": { 
     "app_entry": "spyder", 
     "app_type": "desk", 
     "build": "py34_0", 
     "build_number": 0, 
     "date": "2016-09-26", 
     "depends": [ 
     "jedi >=0.8", 
     "nbconvert", 
     "pep8", 
     "pickleshare", 
     "psutil", 
     "pyflakes", 
     "pygments >=2.0", 
     "pylint", 
     "pyqt 5.*", 
     "python 3.4*", 
     "pyzmq", 
     "qtawesome", 
     "qtconsole >=4.2", 
     "qtpy >=1.1", 
     "rope", 
     "sphinx" 
     ], 
     "icon": "9779607c273dc0786bd972b4cb308b58.png", 
     "license": "MIT", 
     "md5": "1e22cec14b87602a6338a3c46b7991ed", 
     "name": "spyder", 
     "size": 3050583, 
     "summary": "Scientific Python Development Environment", 
     "type": "app", 
     "version": "3.0.0" 
    }, 

现在,在蜘蛛回购,在标签v3.0.0,所述有没有最低版本绝地在

install_requires = [ 
    'rope_py3k' if PY3 else 'rope>=0.9.4', 
    'jedi', 
    'pyflakes', 
    'pygments>=2.0', 
    'qtconsole>=4.2.0', 
    'nbconvert', 
    'sphinx', 
    'pep8', 
    'pylint', 
    'psutil', 
    'qtawesome', 
    'qtpy>=1.1.0', 
    'pickleshare', 
    'pyzmq' 
] 

commit解决这一规定被带来的Spyder上周日,2017年2月5日,被释放v3.1.3,这还没有被添加到默认陈荫罴康达的EL截至上周五,3月10日2017年

由于上述原因,该升级未更新绝地武士的依赖。

由于jedi=0.9.0是在默认可用康达路,你应该能够摆脱这个问题,只是这样做:

conda update jedi